PureBasic - форум

Информация о пользователе

Привет, Гость! Войдите или зарегистрируйтесь.


Вы здесь » PureBasic - форум » Программирование на PureBasic в Linux » Проблема русского языка в логе отладки IDE


Проблема русского языка в логе отладки IDE

Сообщений 1 страница 2 из 2

1

В Linux при ошибке получаю в консоли IDE следующий текст:
 ñâÿçàííîì ñïèñêå (LinkedList) íåò òåêóùåãî ýëåìåíòà.

а должно быть
В связанном списке (LinkedList) нет текущего элемента.

В общем копировал журнал и перекодировал в онлайн перекодировщике, но решил разобраться.
Конкретно строка из файла libraries.catalog. Перевел из 1251 в UTF-8 начало выдавать на английском, то есть файл ему стал нечитабельный. Попробовал кодировку UTF-16 LE, то же самое. Вернул 1251, снова стал использовать русский язык, но с проблемой отображения русских букв.

Писать на официальный форум? Или есть решение?

Отредактировано AZJIO (01.02.2021 14:32:47)

0

2

Дело в неправильной перекодировке. Вероятно IDE пытается ascii отображать как utf-8.

AZJIO написал(а):

ревел из 1251 в UTF-8 начало выдавать на английском, то есть файл ему стал нечитабельный.

В utf-8 может быть только editor.catalog. Остальные если не ascii - игнорируются. Могу предположить что их использует компилятор, который поддерживает только ascii.

AZJIO написал(а):

Писать на официальный форум?

Да. Этот вопрос нужно адресовать Фреду.

0


Вы здесь » PureBasic - форум » Программирование на PureBasic в Linux » Проблема русского языка в логе отладки IDE